Progress28.ru

IT Новости
6 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Excel условное форматирование использовать формулу

Гайд по использованию условного форматирования в Excel

Что такое «Условное форматирование» и для чего оно нужно?

Очень часто, работая в таблицах MS Excel, мы сталкиваемся с большими объемами информации. Согласитесь, работа с данными становится гораздо проще и приятней, если эти данные выделены визуально. Не обязательно вчитываться в текст или цифры, достаточно бросить взгляд и глаз отделит нужные строки по цвету.

Но что самое важное, условное форматирование может в разы Вашу облегчить работу при использовании правил фильтрации, которые также очень популярны при работе с большими объемами данных.

Как создать правило? ​

Студенты сдают тест по теме «Рыночная экономика», оценка за тест ставится в формате зачет/незачет. При этом «зачет» ставится, если набрано не менее 80 баллов. Необходимо выделить оранжевым цветом строки со студентами, которые провалили тестирование.

Рассмотрим, какими правилами можно воспользоваться для решения данной задачи.

Правила выделения ячеек ​

При нажатии на иконку «Условное форматирование» мы видим выпадающий список, первым в нём находится раздел «Правила выделения ячеек». С помощью этих правил можно выделить числовые значения (больше, меньше, между, равно), текстовые (текст содержит) или даты. Также правило даёт возможности найти повторяющиеся значения (все значения, которые встречаются в указанном диапазоне больше одного раза, но это правило не будет выделять разные значения разными цветами).

В данном примере у нас есть числовое значение – количество баллов. Давайте выделим цветом те ячейки, где количество баллов не дотягивает до зачета.

Для этого выделяем диапазон значений, для которого будем применять правило, и выбираем «Правила выделения ячеек» – «Меньше».

После этого видим открывшееся окошко для ввода данных. Вводим количество баллов, необходимое для зачета – 80.

Теперь осталось выбрать формат.

Можно выбрать из предложенного списка, а можно нажать на «Пользовательский формат» и задать его самостоятельно. Для этого в открывшемся окне нужно поменять параметры, в нашем случае – выбрать оранжевую заливку. При необходимости здесь же можно изменить формат текста, шрифт (цвет, начертание и т.д.), границы (цвет, тип линии).

Нажимаем «Ок» и видим результат: ячейки, значение которых было меньше 80, выделены оранжевым цветом.

Ту же процедуру можно повторить и с текстовыми значениями, в нашем случае с отметками зачет/незачет. Для этого необходимо выделить новый диапазон, зайти снова в «Правила выделения ячеек» и «Текст содержит».

В открывшемся окошке вводим текст, который нам необходимо выделить – слово «незачет» и задаем нужный формат точно так же, как делали ранее.

В итоге мы имеем подсвеченные ячейки с нужной отметкой.

Так мы посмотрели наипростейшее применение правил условного форматирования, которые Вы сможете использовать без особых затруднений. Но давайте всё-таки вернёмся к исходному заданию. Нас просили выделить строки со студентами, не сдавшими тест, а нам пока удалось выделить только отдельные ячейки.

Для того, чтобы выделить строку целиком, зайдём в раздел «Управление правилами».

В открывшемся окне выберемся из выпадающего списка «Этот лист» (чтобы увидеть, какие правила у нас применены на листе, а не только к ячейке, на которой в данный момент стоит выделение), и нажмём кнопку «Создать правило».

Здесь мы также видим список правил, которые нам предлагается применить.

Форматировать все ячейки на основании их значений ​

Первое правило в списке – «Форматировать все ячейки на основании их значений». Здесь можно выбрать двухцветную или трехцветную шкалу, гистограмму или набор значков. В нашем случае в этом нет необходимости, но посмотрим для себя на будущее, как это будет выглядеть.

Двухцветная шкала – от минимального значения в выделенном диапазоне к максимальному. Цветовую схему шкалы при необходимости можно изменить.

Трехцветная шкала выглядит поинтересней, здесь можно указать разные цветовые решения для минимальных, промежуточных и максимальных значений.

Гистограмма тоже вполне наглядна. Берет максимальное значение диапазона за 100% и пропорционально заполняет ячейку цветом (цвет также можно изменить).

Наборы значков – тоже интересное решение. Рядом с текстом в ячейке появляется иконка (или вместо текста если поставить галочку в поле «Показать только значок»). Стили значков можно поменять, а также задать для них параметры (какой значок за какой интервал значений отвечает).

Главное не забывайте указывайте диапазон, для которого данное правило будет применяться (это касается любого правила).

И еще важный момент: если в дальнейшем Вы будете использовать правила фильтрации, то важно выбрать такие правила условного форматирования, которые облегчат Вам дальнейшую работу. Например, есть возможность поставить фильтр по цвету или по значку ячейки, но по гистограмме отфильтровать не получится.

Примечание: о том, как правильно и продуктивно работать с правилами фильтрации, читайте в нашей статье «Правила фильтрации в MS Excel».

Форматировать только ячейки, которые содержат

Здесь мы не будем подробно останавливаться, так как это те же самые правила для числовых, которые мы рассматривали вначале: больше, меньше, между, равно и т.д.

Форматировать только первые или последние значения ​

Это правило не так часто применяется, но если Вам нужно выделить, например, 5 ячеек с наивысшим результатом (значения, которые относятся к первым 5), или, наоборот, 10 ячеек с наименьшим результатом (значения, которые относятся к последним 10), то используйте его.

Читать еще:  Как сохранить лист из книги excel

Форматировать только значения, которые находятся выше или ниже среднего ​

Аналогично, выбираем нужный параметр: выше, ниже, равно или ниже и т.п. Среднее значение для диапазона правило определит само, нам нужно только задать необходимый формат (и не забыть про диапазон, к которому будет применяться условие).

Форматировать только уникальные или повторяющиеся значения ​

Это правило, как понятно из его названия, покажет либо все уникальные, либо все повторяющиеся значения в диапазоне на ваш выбор. Например, применим его к столбцу с количеством баллов и увидим, с каким результатом прошли тест более одного человека.

Использовать формулу для определения форматируемых ячеек ​

Ну вот и добрались до последнего пункта в этом меню, и, на наш взгляд – самого универсального. С помощью этого правила мы и выполним условие поставленной задачи.

Нам необходимо выделить всех студентов, у которых стоит «незачет». Для этого пишем формулу: выбираем первую ячейку в столбце «Оценка», пишем «равно» и нужное значение, т.е. «незачет». Настраиваем нужный формат.

Примечание: Если ячейка имеет текстовый формат, но значение ячейки в формуле нужно писать в кавычках.

И обязательно выбираем диапазон. Для этого меняем в выпадающем списке «Текущий фрагмент» на «Этот лист» и выбираем диапазон для созданного правила в графе «Применяется к». В качестве диапазона выбираем строки таблицы целиком, от порядкового номера до оценки. Нажимаем «Применить».

Примечание: Знак $ закрепляет столбец или строку, в зависимости от того, перед буквой (столбец) или цифрой (строка) он стоит. Написание $D$5 показывает, что в формуле будет использоваться только конкретная ячейка.

Так как нам необходимо форматировать всю таблицу, т.е. использовать в формуле весь столбец D, перед строкой символ $ убираем (перед столбцом убирать не нужно). В итоге остается $D5.

Примечание: Сразу убирать этот знак не стоит, т.к. после применения правила диапазон сдвинется по строкам. Самое оптимальное – применить, потом убрать его, затем применить снова.

И теперь мы видим результат: оранжевым цветом выделены строки со студентами, у которых оценка за тест – незачет. Задача выполнена!

Как изменить или удалить правило? ​

На одном листе может применяться более одного правила на один и тот же, либо на разные диапазоны.

По кнопке «Изменить правило» откроется меню, в котором можно отредактировать формулу, изменить параметры форматирования и т.д.

Кнопка «Удалить правило» удалит то, на которым в данный момент стоит выделение.

Также правила можно менять местами, нажимая на стрелочки в этом же меню «вверх» или «вниз». Выполняются правила снизу-вверх, т.е. то, которое сверху, перекрывает нижние (выполняется последним).

Галочка «Остановить, если истина» означает, что при выполнении условия этого правила, другие правила к этим ячейкам применяться не будут.

Вы можете скачать файл с примером, который мы разобрали, и потренироваться на нем самостоятельно.

Сборник формул для условного форматирования

В данной статье собран список формул, которые можно использовать в условном форматировании ячеек, заданным при помощи формулы:

  • Excel 2003 : Формат (Format)Условное форматирование (Conditional formatting)формула;
  • Excel 2007-2010 : вкладка Главная (Home)Условное форматирование (Conditional formatting)Создать правило (New rule)Использовать формулу для определения форматируемых ячеек (Use a formula to determine which cells to format)

Подробнее об условном форматировании можно прочитать в статье: Основные понятия условного форматирования и как его создать

Все условия приведены для диапазона A1:A20 . Это означает, что для корректного выполнения условия необходимо выделить диапазон A1:A20 (столбцов может быть больше), начиная с ячейки A1 , после чего назначить условие.
Если выделять необходимо не с первой строки, а скажем, с 4-ой, то и выделить надо будет диапазон A4:A20 и в формуле для условия указывать в качестве критерия первую ячейку выделенного диапазона — A4 .

Если необходимо выделять форматированием не только конкретную ячейку, удовлетворяющую условию, а всю строку таблицы на основе ячейки одного столбца, то перед установкой правила необходимо выделить всю таблицу, строки которой необходимо форматировать, а ссылку на столбец с критерием закрепить:
= $A1 =МАКС( $A$1:$A$20 )
при выделенном диапазоне A1:F20 (диапазон применения условного форматирования), будет выделена строка A7:F7 , если в ячейке A7 будет максимальное число.

Так же можно применять не к конкретно одному столбцу, а к полностью диапазону. Но в этом случае надо знать принцип смещения ссылок в формулах, чтобы условия применялись именно к нужным ячейкам. Например, если задать условие для диапазона B1:D10 в виде формулы: = B1 A1 , то цветом будут выделены ячейки столбца B, если значение ячейки столбца А в той же строке меньше( B1, B3). При этом если ячейки столбца D меньше ячеек столбца C в той же строке — они тоже будут выделены( D1 , D5 ).

Читать еще:  700 столбец в excel
  • Выделение ячеек с числами:
    =ЕЧИСЛО( A1 )
  • Выделение ячеек с числами, но не учитывая нули:
    =И(ЕЧИСЛО( A1 ); A1 <>0)
  • Выделение строк со значением больше 0:
    = A1 >0
  • Выделение строк со значением в диапазоне от 3 до 10:
    =И( A1 >=3; A1
  • Выделение в диапазоне $A$1:$A$20 ячейки с максимальным значением:
    = A1 =МАКС( $A$1:$A$20 )
  • Выделение в диапазоне $A$1:$A$20 ячейки с минимальным значением:
    =И(ЕЧИСЛО( A1 ); A1 =МИН( $A$1:$A$20 ))
  • Выделение в диапазоне $A$1:$A$20 ячейки со вторым по величине числом. Т.е. из чисел 1,2,3,4,5,6,7 будет выделено число 6:
    = A1 =НАИБОЛЬШИЙ( $A$1:$A$20 ;2)

  • Выделение ячеек с любым текстом:
    =ЕТЕКСТ( A1 )
  • Выделение ячеек с текстом Итог:
    = A1 =»Итог»
  • Выделение ячеек, содержащих текст Итог:
    =СЧЁТЕСЛИ( A1 ;»*итог*»)
    =НЕ(ЕОШ(ПОИСК(«итог»; A1 )))
  • Выделение ячеек, не содержащих текст Итог:
    =СЧЁТЕСЛИ( A1 ;»*итог*»)=0
    =ЕОШ(ПОИСК(«итог»; A1 ))
  • Выделение ячеек, текст которых начинается со слова Итог:
    =ЛЕВСИМВ( A1 ;4)=»Итог»
  • Выделение ячеек, текст которых заканчивается на слово Итог:
    =ПРАВСИМВ( A1 ;4)=»Итог»

  • Выделение текущей даты:
    = A1 =СЕГОДНЯ()
  • Выделение ячейки с датой, больше текущей:
    = A1 >СЕГОДНЯ()
  • Выделение ячейки с датой, которая наступит через неделю:
    = A1 =СЕГОДНЯ()+7
  • Выделение ячеек с датами текущего месяца(любого года):
    =МЕСЯЦ( A1 )=МЕСЯЦ(СЕГОДНЯ())
  • Выделение ячеек с датами текущего месяца текущего года:
    =И(МЕСЯЦ( A1 )=МЕСЯЦ(СЕГОДНЯ());ГОД( A1 )=ГОД(СЕГОДНЯ()))
    или
    =ТЕКСТ( A1 ;»ГГГГММ»)=ТЕКСТ(СЕГОДНЯ();»ГГГГММ»)
  • Выделение ячеек с выходными днями:
    =ДЕНЬНЕД( A1 ;2)>5
  • Выделение ячеек с будними днями:
    =ДЕНЬНЕД( A1 ;2)
  • Выделение ячеек, входящих в указанный период(промежуток) дат:
    =И( $A1 >ДАТА(2015;9;1); $A1

  • Выделение различий в ячейках по условию:
    = A1 <> $B1
  • Выделение ячейки, если ячейка следующего столбца(B) этой же строки меньше:
    = A1 > B1
  • Выделение строк цветом через одну:
    =ОСТАТ(СТРОКА();2)
  • Выделение строк цветом, если значение ячейки столбца A присутствует в диапазоне $F$1:$H$5000 :
    =СЧЁТЕСЛИ( $F$1:$H$5000 ; A1 )
  • Выделение строк цветом, если значение ячейки столбца A отсутствует в диапазоне $F$1:$H$5000 :
    =СЧЁТЕСЛИ( $F$1:$H$5000 ; A1 )=0
  • Выделение цветом ячейки, если её значение в диапазоне A1:A20 второе по счету:
    =СЧЁТЕСЛИ( $A$1:$A1 ; A1 )=2
  • Выделение ячеек, содержащих ошибки (#ЗНАЧ!; #Н/Д; #ССЫЛКА! и т.п.). Помимо просто выявления ячеек с ошибками можно применять, когда необходимо скрыть ошибочные значения в ячейках(назначив цвет шрифта таким же, как и цвет заливки):
    =ЕОШИБКА( A )
  • Выделение непустых ячеек в столбце A :
    = $A1 <>«»
  • Статья помогла? Поделись ссылкой с друзьями!

    Условное форматирование с использованием формул

    В Excel условное форматирование позволяет использовать формулы в критериях вместо значений. В таком случаи критерий автоматически получает результирующие значение, которое выдает формула в результате вычислений.

    Условное форматирование по формуле

    Формулы в качестве критериев можно использовать практически любые, которые возвращают значения. Но для логических формул (возвращающие значения ИСТИННА или ЛОЖЬ) в Excel предусмотрен отдельный тип правил.

    При использовании логических формул в качестве критериев следует:

    1. Выбрать инструмент: «Главная»-«Стили»-«Условное форматирование»-«Управление правилами».
    2. В появившемся окне «Диспетчер правил условного форматирования» нажать на кнопку «Создать правило».
    3. В списке опций «Выберите тип правила:» выберите опцию «Использовать формулу для определения форматируемых ячеек».
    4. В поле ввода «Форматировать значения, для которых следующая формула является истинной» ввести логическую формула, а нажав на кнопку «Формат» указать стиль оформления ячеек.

    

    Правила использования формул в условном форматировании

    При использовании формул в качестве критериев для правил условного форматирования следует учитывать некоторые ограничения:

    1. Нельзя ссылаться на данные в других листах или книгах. Но можно ссылаться на имена диапазонов (так же в других листах и книгах), что позволяет обойти данное ограничение.
    2. Существенное значение имеет тип ссылок в аргументах формул. Следует использовать абсолютные ссылки (например, =СУММ($A$1:$A$5) на ячейки вне диапазона условного форматирования. А если нужно ссылаться на несколько ячеек непосредственно внутри диапазона, тогда следует использовать смешанные типы ссылок (например, A$1).
    3. Если в критериях формула возвращает дату или время, то ее результат вычисления будет восприниматься как число. Ведь даты это те же целые числа (например, 01.01.1900 – это число 1 и т.д.). А время это дробные значения части от целых суток (например, 23:15 – это число 0,96875).

    Иногда встроенные условия формата ячеек не удовлетворяют всех потребностей пользователей. Добавление собственной формулы в условное форматирование обеспечивает дополнительную функциональность, которая не доступна в строенных функциях данного инструмента. Excel предоставляет возможность использовать много критериев или применять сложные вычисления, что дает широкое поле к применению сложных настроек критериев для автоматически генерированного презентабельного экспонирования важной информации.

    Практический пример использования логических функций и формул в условном форматировании для сравнения двух таблиц на совпадение значений.

    Условное форматирование в MS Excel с примерами

    Условное форматирование в Эксель – этот тот инструмент, который делит работу на до и после его изучения. Суть в том, что при наступлении некоторого условия ячейки форматируются автоматически. Например, если число превышает значение 100, шрифт становится красным полужирным курсивом; когда до наступления платежа остается 2 дня, ячейка с датой подсвечивается желтым цветом; перевыполнение плана продаж на 5% и более окрашивается в зеленый цвет и т.д. и т.п.

    Читать еще:  Excel функция содержит текст

    Вот упрощенный, но реальный пример. Есть отчет о товарных запасах.

    Менеджер по закупкам отслеживает те позиции, которые требуют пополнения. Для этого он смотрит в последнюю колонку, где рассчитывается товарный запас (ТЗ) в неделях. Если ТЗ меньше, скажем, 3-х, то нужно готовить заказ. Если меньше 2-х, то возникает риск дефицита и заказ нужно размещать срочно. Если в таблице десятки позиций, то просмотр каждой строки займет довольно много времени. А теперь та же таблица, где после применения условного форматирования значения ниже пороговых подсвечиваются некоторым цветом.

    Согласитесь, так гораздо нагляднее. В реальности условия сложнее, а данные постоянно меняются. Поэтому эффект от применения условного форматирования – это многочасовая экономия времени ежедневно! Теперь для оценки запасов достаточно взглянуть на таблицу, а не анализировать каждую ячейку. Много желтого – пора действовать, много красного – ситуация критическая!

    Для настройки условного формата следует воспользоваться соответствующей командой на вкладке Главная.

    При ее нажатии открывается меню.

    Верхние 5 команд – это готовые сценарии для быстрого условного форматирования. Чтобы ими воспользоваться достаточно выбрать нужный вариант и сделать минимальные настройки. Эти сценарии мы рассмотрим ниже.

    В нижней части еще три команды, с помощью которых происходит ручное создание, удаление и управление правилами условного форматирования. О них также поговорим.

    Все сценарии разбиты на категории:

    – Правило выделения ячеек

    – Правило отбора первых и последних значений

    Правила выделения ячеек применяют для ячеек, которые сравниваются с определенным значением. Возможны различные варианты, которые показаны на рисунке ниже.

    Больше… Если значение ячейки, к которой применяется правило выделения, больше указанного значения, то в силу вступает заданный формат.

    Пороговое значение указывается в левой части окна (сейчас там 80), готовый формат выбирается из выпадающего списка справа. Можно, конечно, и самому задать. Диалоговые окна для других условий похожи, поэтому ниже приводятся только те, которые могут вызвать затруднения.

    Меньше… Форматируются ячейки, у которых значение меньше заданного порога.

    Между… Форматирование наступает, если содержимое ячейки находится внутри заданных границ.

    Равно… если значение или текст в ячейке совпадает с условием.

    Текст содержит… Если совпадает только часть текста (слово, код, комбинация символов и т.д).

    Дата… Возможность форматировать периоды отстоящие от текущей даты, например, сегодня, вчера, последние 7 дней, следующий месяц и др. Условное форматирование даты полезно при контроле платежей, отгрузок и т.п.

    Повторяющиеся значения… выделяются ячейки с одинаковым содержимым. Отличный способ найти дубликаты (повторы). В настройках можно выбрать и обратный вариант – выделить только уникальные значения.

    Правила отбора первых и последних значений выделяют наибольшие или наименьшие значения. Помогают анализировать данные, показывая приоритеты и «слабые места».

    Первые 10 элементов… Выделяются первые топ–10 ячеек. Количество регулируется в диалоговом окне (можно сделать топ-5, топ-20 и др.).

    Первые 10%… Выделяются 10% наибольших значений. Долю можно изменить.

    Последние 10 элементов… Аналогично с первым пунктом, только форматируются наименьшие значения.

    Последние 10%… Наименьшие 10% или другая доля от всех элементов.

    Выше среднего… Форматируются все значения, которые больше средней арифметической.

    Ниже среднего… Ниже средней арифметической.

    Гистограммы позволяют в каждую ячейку с числом добавить столбец линейной гистограммы, размер которой определяется относительно максимального значения в выделенном диапазоне.

    Помогает визуализировать небольшой набор данных без использования отдельных диаграмм. После применения выглядит примерно так.

    Цветные шкалы также автоматически определяют максимальное и минимальное значение в диапазоне и форматирует каждую ячейку по цвету, который соответствует значению, изображая что-то вроде тепловой карты.

    Например, наибольшее значения – это красное, наименьшее – зеленое, а остальные ячейки – это плавный переход от одного цвета к другому через промежуточный белый.

    Набор значков – эффектный, но не очень гибкий способ визуализации. Каждой ячейке присваивается свой значок в соответствии с выбранным стилем.

    В ячейках Excel выглядит так.

    Все картинки выше были сделаны с помощью стилей по умолчанию. Чтобы внести изменения, нужно выделить диапазон и перейти в управление правилами.

    Откроется диалоговое окно, где можно создать новое, изменить или удалить правило. Часто используют сразу несколько правил.

    После нажатия кнопки «Изменить правило…» откроется окно, вид которого зависит от редактируемого правила.

    Здесь также есть куча настроек, но мы их пока опустим. В целом там все интуитивно понятно. Нужно только поэкспериментировать. Практика – лучший учитель.

    Если какое-то правило условного форматирования нужно удалить, то после выделения диапазона следует выбрать команду удаления.

    Условное форматирование – это три шага вперед на пути к профессиональному использованию Excel. Поэтому рекомендую незамедлительно внедрить в практику.

    Хочется только напомнить, что при использовании любого форматирования очень важно не переусердствовать. Всегда нужно помнить о главной цели: облегчение восприятия информации и привлечение внимания к наиболее важным местам. Например, формат ниже – это неправильно.

    Старайтесь также, чтобы количество используемых цветов было не больше трех. Иначе внимание рассеивается и может стать еще хуже.

    Ссылка на основную публикацию
    Adblock
    detector