Progress28.ru

IT Новости
3 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Округлт excel на английском

Формула Округления ОКРУГЛ() или ROUND() в Excel

Одним из вариантов представления числа до необходимого с заданным количеством знаков разряда является формула Округление ОКРУГЛ() или ROUND() в английском варианте. Она округляет число по стандартным математическим правилам.

Рассмотрим эту формулу, ее вариации и еще приведу пример как можно округлять значения другим способом.

Возьмем абстрактные числа требующие округления:

Начнем писать в строке функций формулу =ОКРУГЛ( и нажмем кнопку Fx:

В окне аргументы функции в поле число указываем адрес ячейки для округления (B2), в поле число_разрядов необходимое число разрядов до которого необходимо округлить (например, 2):

Предварительно Excel уже показывает результат, нажимаем кнопку ОК и протягиваем формулу до конца столбца (до ячейки C5):

Ничего сложного, быстро и удобно.

Формула ОКРУГЛВВЕРХ() или ROUNDUP().

Позволяет произвести округление как и в прошлом примере, но при это вы задает правило округлять последний разряд в большую сторону. Аргументы функции точно такие же, повторяем все предыдущие действия, только формулу теперь пишем ОКРУГЛВВЕРХ(). Результатом будет:

Видно, что последние разряда первого и последнего числа отличаются от предыдущего примера, так как тоже округлились в большую сторону.

Формула ОКРУГЛВНИЗ() или ROUNDDOWN()

Как в предыдущем примере, только округление последнего разряда будет в меньшую сторону. По идеи в нашем примере от функции ОКРУГЛ() должны отличаться цифры №2 и 3. Проверим:

Формула ОКРГУЛТ() или MROUND()

Но есть еще одна функция округления это функция ОКРУГЛТ() или MROUND(). Она позволяет найти ближайшее большее число кратное точности. Для простоты упростим наш пример:

В строке функций начинаем набирать формулу =ОКРУГЛТ() и нажимаем Fx. В окне аргументов вводим число и укажем точность равной 3, получаем результат:

Читать еще:  Как активировать функцию стандотклон в excel

Для первого числа ответ 9. Это ближайшее большее число кратное цифре 3.

Округление с помощью форматов.

Заменить функцию округления (в стандартном ее исполнении) можно задав формат числа. Для нашего примера выделяем ячейки:

Нажимаем ПКМ – формат ячеек.

В числовых форматах выбираем числовой:

Указываем число десятичных знаков, мы округляли до 3 знаков, укажем так и здесь:

Нажимаем ОК. Наблюдаем результат:

На этом с округлением значений все. Пишите в комментариях пожелания и вопросы.

Примеры функций ОКРГУЛ и ОКРУГЛТ для округления чисел в Excel

Функция ОКРУГЛ используется для округления действительных чисел до требуемого количества знаков после запятой и возвращает округленное значение. Например, для округления числа 1,22365 до двух знаков после запятой можно ввести формулу =ОКРУГЛ(1,22365;2), которая вернет значение 1,22.

Функция ОКРУГЛТ используется для округления чисел с требуемой точностью и возвращает округленное значение. Функция ОКРУГЛТ принимает во внимание значение, являющееся остатком от деления округляемого числа на указанную точность. Операция округления будет произведена только в том случае, если оно равно или больше ½ точности.

Примеры использования функций ОКРУГЛ и ОКРУГЛТ в Excel

Пример 1. Стоимость валюты составляет 70 рублей. Определить наибольшее количество валюты, которое можно приобрести, если покупатель взял с собой 2200 рублей. Как известно, в обменных пунктах выдают только купюры.

Для решения используем следующую формулу:

Функция ОКРУГЛ принимает следующие параметры:

  • B3/B2 – частное от деления суммы имеющихся рублей на стоимость одной валюты;
  • 0 – значение, указывающее на то, что округление будет выполняться до целого числа.

Если произведение округленного значения и курса валюты превышает сумму имеющихся рублей, то из первого будет вычтена единица, иначе будет возвращено просто округленное значение.

Читать еще:  Проверка диапазона в excel

То есть, 2200 рублей можно поменять не более чем на 31 у.е.

Как перевести мили в километры используя функцию ОКРУГЛ в Excel

Пример 2. Спидометр автомобиля отображает скорость в единицах измерения мили/ч. 1 миля = 1609 м (1,609 км). Определить скорость автомобиля в километрах часов (округленно до одного знака после запятой), если на данный момент спидометр показывает скорость 75 миль/ч.

Формула для решения:

  • B3*B2 – перевод миль/ч в км/ч;
  • 1 – количество знаков после запятой для округления.

Калькулятор расчета мощности кондиционера по площади комнаты в Excel

Пример 3. Для помещения площадью 60 кв. м и высотой потолка 2,7 м необходимо подобрать кондиционер по мощности. Поставщики предлагают кондиционеры мощностью от 2 кВт с шагом 0,5 кВт. Определить подходящий кондиционер.

Искомая мощность рассчитывается как произведение площади, высоты потолка и коэффициента q. Используем следующую формулу:

Для автоматического выбора кондиционера используем формулу:

В данном случае функция ЕСЛИ выполняет проверку дробной части найденного значения мощности на принадлежность к промежутку значений от 0 до 0,25 и от 0,5 до 0,75. Это необходимо для правильного выбора кондиционера по мощности. Например, если бы результатом расчетов являлась мощность 5,2 кВт, функция ОКРУГЛТ(5,2;0,5) вернула бы значение 5. Однако мощность выбранного кондиционера должна быть равной или больше расчетной. Поэтому в этом случае к результату будет добавлено значение 0,5.

Результат расчета мощности кондиционера по площади комнаты:

Особенности использования функций ОКРУГЛ и ОКРУГЛТ в Excel

Обе функции используются для округления числовых значений наряду с прочими функциями ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ. Функция ОКРУГЛ имеет следующую синтаксическую запись:

  • число – обязательный аргумент, характеризующий числовое значение, для которого требуется выполнение операции округления;
  • число_разрядов – обязательный аргумент, характеризующий количество знаков после запятой в числе после округления.
Читать еще:  Excel названия столбцов цифрами

Функция ОКРУГЛТ имеет следующий синтаксис:

  • число – обязательный аргумент, соответствует одноименному аргументу функции ОКРУГЛ;
  • точность – обязательный аргумент, характеризующий числовое значение точности округления числа.
Ссылка на основную публикацию
Adblock
detector